New machine setup up 101?

Avatar

By FrankNPrinter 27 February 2017 23:04

Member · 47 comments

Hi,
i have a folgertech ft5 with a duet wifi board. It appears to be able to move on all axis' but now i have no idea what to do. End stop sensors light up on board when triggered but do not appear to stop when hit from commands at either touch screen move or web page command. config below. range of movement doesn't spear right to me either but no idea how to calibrate without end sensors working right. I also have a bl touch and that is remed out at the moment. it appeared to fire probe fine but still not right crashed ph into bed and ruined pei sheet. 😩 any help for a newbie would be appreciated!

; Configuration file for Duet WiFi (firmware version 1.17)
; executed by the firmware on start-up
;
; generated by RepRapFirmware Configuration Tool on Thu Feb 23 2017 12:18:06 GMT-0500 (Eastern Standard Time)

; General preferences
M111 S0 ; Debugging off
G21 ; Work in millimetres
G90 ; Send absolute coordinates...
M83 ; ...but relative extruder moves
M555 P1 ; Set firmware compatibility to look like RepRapFirmare
M208 X0 Y0 Z0 S1 ; Set axis minima
M208 X252 Y174 Z56 S0 ; Set axis maxima

; Endstops
M574 X1 Y2 Z2 S0 ; Define active low and unused microswitches
M558 P1 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
;G31 P600 X0 Y28 Z2.5 ; Set Z probe trigger value, offset and trigger height

;##BLTouch Servo Settings thermistor ADC correction
;switch.servo.enable true
;switch.servo.input_on_command M280 S3.0 # M280 S7.5 Would be midway
;switch.servo.input_off_command M280 S7.0 # Same as M280 S0 0% duty cycle, effectivley off
;switch.servo.output_pin 1.23 # Must be a PWM capable pin
;switch.servo.output_type hwpwm # H/W PWM output settable
;switch.servo.pwm_period_ms 20 # Set Period to 20ms (50Hz) - Default is 50Hz
;gamma_min_endstop            nc                 # normally 1.28. Change to nc to prevent conflict, not needed on Azteeg X5
;zprobe.enable                true    #  true to enable a zprobe
;zprobe.probe_pin             1.28!^  # pin probe is attached to if NC remove the !, Azteeg X5 this is 1.29
;zprobe.slow_feedrate         5                  # mm/sec probe ;feed rate
;#zprobe.debounce_ms          1                  # set if noisy
;zprobe.fast_feedrate         100                # move feedrate
;zprobe.probe_height          5                  # how much above bed to start probe NB only needed for G32 on delta
;zprobe.return_feedrate       0                  # feedrate after a probe, default 0 is double of slow_feedrate (mm/s)


; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S1 ; Drive 1 goes forwards
M569 P2 S1 ; Drive 2 goes forwards
M569 P3 S1 ; Drive 3 goes forwards
M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z10240 E420 ; Set steps per mm
M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
M906 X1800 Y1800 Z1800 E1800 I30 ; Set motor currents (mA) and motor idle factor in per cent
M84 S30 ; Set idle timeout

; Heaters
M143 S260 ; Set maximum heater temperature to 260C
M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

; Tools
M563 P0 D0 H1 ; Define tool 0
G10 P0 X0 Y0 ; Set tool 0 axis offsets
G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

; Network
M550 PFrankNPrninter ; Set machine name
M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

; Fans
M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

; Custom settings are not configured

Avatar

By FrankNPrinter 28 February 2017 20:21

Member · 47 comments

UPDATE, movement works and end stops light up when activated but do not appear to stop movement. is this normal? bed and ph heaters work fine, just need to reverse extruder motor. still no idea how to go about calibrating movement. anyone know of a set of instructions for this?

Avatar

By dc42 28 February 2017 22:03

Administrator · 2,617 comments

As with most other firmwares, the endstop switches are only monitored during homing moves. Once the printer is homed, the movement limits set by your M208 commands in config,g are applied.

You can reverse the extruder direction by changing S1 to S0 in the M569 P3 command.

By "calibrating movement", I presume you mean getting the motors to move the exact amount commanded. This is done by adjusting the steps/mm in the M92 command or commands. Normally, it is just the extruder steps/mm that need calibrating, because the X, Y and Z steps/mm are determined by your belts, pulleys and leadscrews.

HTH David


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By FrankNPrinter 1 March 2017 17:14

Member · 47 comments

Thank you Sir! I was able to get x and y to home and i think i figured out z travel issues as it moves the full 450mm  and other 2 axis are close to factory range - obstacles. When i home Z, it still crashes into the print head. I also have a bltouch so am not sure if that is messing things up? I have end stop sensors on x y and z so not sure why z is being so difficult as sensor does light up but here is the updated config. Note z = -450 to 0 min \ max since up and down are  correct, i am guessing i don't want to reverse motor right? Are these values correct for that? it starts at top 0 and goes down to -450. End stop is at top on 574, should z=2? tried it both ways i think...

; Configuration file for Duet WiFi (firmware version 1.17)
; executed by the firmware on start-up
;
; generated by RepRapFirmware Configuration Tool on Thu Feb 23 2017 12:18:06 GMT-0500 (Eastern Standard Time)

; General preferences
M111 S0 ; Debugging off
G21 ; Work in millimetres
G90 ; Send absolute coordinates...
M83 ; ...but relative extruder moves
M555 P1 ; Set firmware compatibility to look like RepRapFirmare
M208 X3 Y0 Z-450 S1 ; Set axis minima
M208 X256 Y282 Z0 S0 ; Set axis maxima

; Endstops
M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
M558 P1 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
;G31 P600 X0 Y28 Z2.5 ; Set Z probe trigger value, offset and trigger height

;##BLTouch Servo Settings thermistor ADC correction
;switch.servo.enable true
;switch.servo.input_on_command M280 S3.0 # M280 S7.5 Would be midway
;switch.servo.input_off_command M280 S7.0 # Same as M280 S0 0% duty cycle, effectivley off
;switch.servo.output_pin 1.23 # Must be a PWM capable pin
;switch.servo.output_type hwpwm # H/W PWM output settable
;switch.servo.pwm_period_ms 20 # Set Period to 20ms (50Hz) - Default is 50Hz
;gamma_min_endstop            nc                 # normally 1.28. Change to nc to prevent conflict, not needed on Azteeg X5
;zprobe.enable                true    #  true to enable a zprobe
;zprobe.probe_pin             1.28!^  # pin probe is attached to if NC remove the !, Azteeg X5 this is 1.29
;zprobe.slow_feedrate         5                  # mm/sec probe ;feed rate
;#zprobe.debounce_ms          1                  # set if noisy
;zprobe.fast_feedrate         100                # move feedrate
;zprobe.probe_height          5                  # how much above bed to start probe NB only needed for G32 on delta
;zprobe.return_feedrate       0                  # feedrate after a probe, default 0 is double of slow_feedrate (mm/s)


; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S0 ; Drive 1 goes Backwards
M569 P2 S1 ; Drive 2 goes forwards
M569 P3 S0 ; Drive 3 goes Backwards
M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z1280 E420 ; Set steps per mm
M566 X900 Y900 Z900 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z1000 E1200 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
M906 X1800 Y1800 Z1800 E1800 I30 ; Set motor currents (mA) and motor idle factor in per cent
M84 S30 ; Set idle timeout

; Heaters
M143 S260 ; Set maximum heater temperature to 260C
M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

; Tools
M563 P0 D0 H1 ; Define tool 0
G10 P0 X0 Y0 ; Set tool 0 axis offsets
G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

; Network
M550 PFrankNPrninter ; Set machine name
M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

; Fans
M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

; Custom settings are not configured

Avatar

By dc42 1 March 2017 17:33

Administrator · 2,617 comments

Please read the section on Z homing here https://duet3d.com/wiki/Configuring_Rep … ming_files.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By FrankNPrinter 1 March 2017 19:34

Member · 47 comments

You are the man! 😁 X, Y and Z all home  now! To be honest, i had read that section at least 3 times already. Apparantly it is slowly starting to sink in LOL Now on to BL Touch and extruder cal and i should be printing (finger crossed)

Avatar

By iDevelo 1 March 2017 19:59

Member · 193 comments

I presume you don't have Z-450 in M208 anymore?

Avatar

By iDevelo 1 March 2017 20:03

Member · 193 comments

I also suggest X & Y endstops are highend so 0x0 is front left on the build plate if you homing to back right of the ft5.

Avatar

By shojidoug 1 March 2017 21:38

Member · 11 comments

Hi Frank, I am also putting together an FT-5 also with a duet wifi. Could you please share you completed config file? There are some differences in our setups but the majority of it would put me days ahead in the learning curve.
Thanks very much 😁

Avatar

By iDevelo 3 March 2017 14:57

Member · 193 comments
shojidoug wrote

Hi Frank, I am also putting together an FT-5 also with a duet wifi. Could you please share you completed config file? There are some differences in our setups but the majority of it would put me days ahead in the learning curve.
Thanks very much 😁

Here's mine:

;;
;; Folgertech FT5 Configuration
;;

M111 S0                                        ; Debugging off
G21                                            ; Work in millimetres
G90                                            ; Send absolute coordinates...
M83                                            ; ...but relative extruder moves
M555 P2                                        ; Set firmware compatibility to look like Marlin
M208 X0 Y0 Z0 S1                               ; Set axis minima
M208 X305 Y304 Z410 S0                         ; Set axis maxima

M574 Y2 X2 Z0 S0                               ; Define active high microswitches

M558 P1 X0 Y0 Z1 H5 F120 T6000                 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
G31 P500 X0 Y0 Z2.09                           ; Set Z probe trigger value, offset and trigger height

M584 X0 Y1:4 Z2 E3                             ; Map to specific drives

M569 P0 S0                                     ; Drive 0 goes forwards - X
M569 P1 S0                                     ; Drive 1 goes forwards - Y
M569 P2 S1                                     ; Drive 2 goes forwards - Z
M569 P3 S1                                     ; Drive 3 goes forwards - E0
M569 P4 S1                                     ; Drive 3 goes forwards - Y

M350 X32 Y32 Z32 E32 I1                        ; Configure microstepping with interpolation
M92 X160 Y160 Z798 E984.90                     ; Set steps per mm
M566 X1200 Y1200 Z60 E120                      ; Set maximum instantaneous speed changes (mm/min)
M203 X8000 Y8000 Z600 E1200                    ; Set maximum speeds (mm/min)
M201 X1500 Y1500 Z500 E250                     ; Set accelerations (mm/s^2)
M906 X1000 Y1000 Z1200 E900 I30                ; Set motor currents (mA) and motor idle factor in per cent
M84 S30                                        ; Set idle timeout

M143 S260                                      ; Set maximum heater temperature to 260C
M305 P0 T100000 B3950 C0 R4700                 ; Set thermistor + ADC parameters for heated bed (Heater 0)
M305 P1 T100000 B4388 C0 R4700                 ; Set thermistor + ADC parameters for E0 (Heater 1)

M307 H0 A281.7 C430.4 D4.4 B0                  ; Bed PID
M307 H1 A344.7 C122.8 D5.5 B0                  ; Hotend PID

M563 P0 D0 H1                                  ; Define tool 0
G10 P0 X0 Y0                                   ; Set tool 0 axis offsets
G10 P0 R0 S0                                   ; Set initial tool 0 active and standby temperatures to 0C

M550 PFT5                                      ; Set machine name
M552 P0.0.0.0 S1                               ; Enable network and acquire dynamic address via DHCP

M106 P0 S0 I0 F500 H-1                         ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P1 S255 I0 F500 H1 T50                    ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
M106 P2 S255 I0 F500 H1 T50                    ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

T0                                             ; Select first tool
Avatar

By shojidoug 5 March 2017 22:42

Member · 11 comments

Thank you sir! 😁

Avatar

By FrankNPrinter 13 March 2017 20:37

Member · 47 comments

well it took more effort than I would like to admit but I am back online with an old win7 32 bit box so have access to system again. as promised not that it will be of any use but here is my current config. I need to work out the details for the m584 command then will get back to bltouch hopefully. Pretty sure I am missing a few adjustments like power to e1 etc. can someone check this for me and let me know what I screwed up? 😁 I relocated 2nd z motor to series port and 2nd y motor to e1 guessing I need to update several other lines as well???

; Configuration file for Duet WiFi (firmware version 1.17)
; generated by RepRapFirmware Configuration Tool on Thu Feb 23 2017 12:18:06 GMT-0500 (Eastern Standard Time)

; General preferences
M111 S0 ; Debugging off
G21 ; Work in millimetres
G90 ; Send absolute coordinates...
M83 ; ...but relative extruder moves
M555 P1 ; Set firmware compatibility to look like RepRapFirmare
M208 X0 Y0 Z0 S1 ; Set axis minima
M208 X256 Y269 Z450 S0 ; Set axis maxima

; Endstops
M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches

; BLTouch
;M307 H3 A-1 C-1 D-1
;M558 P5 X0 Y0 Z1 H3 F200 T5000       

M584 X0 Y1:5 Z2:3 E4

; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S0 ; Drive 1 goes Backwards
M569 P2 S0 ; Drive 2 goes Backwards
M569 P3 S0 ; Drive 3 goes Backwards
M569 P4 S0 ; Drive 4 goes Backwards
M569 P5 S1 ; Drive 5 goes Forwards

M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z1280 E378.38 ; Set steps per mm
M566 X900 Y900 Z900 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z1000 E1200 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
M906 X1800 Y1800 Z1800 E1800 I30 ; Set motor currents (mA) and motor idle factor in per cent
M84 S30 ; Set idle timeout

; Heaters
M143 S260 ; Set maximum heater temperature to 260C
M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

; Tools
M563 P0 D0 H1 ; Define tool 0
G10 P0 X0 Y0 ; Set tool 0 axis offsets
G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

; Network
M550 PFrankNPrninter ; Set machine name
M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

; Fans
M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

; Custom settings are not configured

Avatar

By FrankNPrinter 13 March 2017 21:04

Member · 47 comments

here arethe updates I have done based on m92 command

M584 X0 Y1:5 Z2:3 E4

; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S0 ; Drive 1 goes Backwards
M569 P2 S0 ; Drive 2 goes Backwards
M569 P3 S0 ; Drive 3 goes Backwards
M569 P4 S0 ; Drive 4 goes Backwards
M569 P5 S1 ; Drive 5 goes Forwards
M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z1280 E378.38:320 ; Set steps per mm
M566 X900 Y900 Z900 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z1000 E1200:6000 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250:20 ; Set accelerations (mm/s^2)
M906 X1500 Y1500 Z1500 E1500:1500 I30 ; Set motor currents (mA)

Avatar

By FrankNPrinter 14 March 2017 00:21

Member · 47 comments

y and z have 1 motor going against the other so I made this change and same result. I know I missed something but am clueless... any idea what I did wrong here?
M584 X0 Y1:5 Z2 E4

; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S0 ; Drive 1 goes Backwards
M569 P2 S0 ; Drive 2 goes Backwards
M569 P3 S0 ; Drive 3 goes Backwards
M569 P4 S0 ; Drive 4 goes Backwards
M569 P5 S0 ; Drive 5 goes Backwards
M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z1280 E378.38:320 ; Set steps per mm
M566 X900 Y900 Z900 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z1000 E1200:6000 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250:20 ; Set accelerations (mm/s^2)
M906 X1500 Y1500 Z1500 E1500:1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
M84 S30 ; Set idle timeout

Avatar

By FrankNPrinter 14 March 2017 00:46

Member · 47 comments

think I found a wiring issue and fixed it. now both y motors are wired the same but they are fighting each other so something still wrong same with z
M584 X0 Y1:5 Z2:3 E4

; Drives
M569 P0 S0 ; Drive 0 goes Backwards
M569 P1 S0 ; Drive 1 goes Backwards
M569 P2 S0 ; Drive 2 goes Backwards
M569 P3 S0 ; Drive 3 goes Backwards
M569 P4 S0 ; Drive 4 goes Backwards
M569 P5 S1 ; Drive 5 goes Forwards
M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
M92 X320 Y320 Z1280 E378.38:320 ; Set steps per mm
M566 X900 Y900 Z900 E120 ; Set maximum instantaneous speed changes (mm/min)
M203 X6000 Y6000 Z1000 E1200:6000 ; Set maximum speeds (mm/min)
M201 X500 Y20 Z250 E250:20 ; Set accelerations (mm/s^2)
M906 X1500 Y1500 Z1500 E1500:1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
M84 S30 ; Set idle timeout

Avatar

By FrankNPrinter 14 March 2017 00:48

Member · 47 comments

z motors are connected to 2 z ports and y left to y port y right to e1 port

Avatar

By FrankNPrinter 18 March 2017 04:26

Member · 47 comments

x and y are working but z does not z motors are connected to 2 z ports and appear to be going in opposite directions. did I wire something wrong or is something configured wrong here?
M584 X0 Y1:4 Z2 E3

; Drives
M569 P0 S0            ; Drive 0 goes forwards - X
M569 P1 S0            ; Drive 1 goes forwards - Y
M569 P2 S1            ; Drive 2 goes forwards - Z
M569 P3 S1            ; Drive 3 goes forwards - E0
M569 P4 S1            ; Drive 4 goes forwards - Y

Avatar

By FrankNPrinter 18 March 2017 13:02

Member · 47 comments

still got something wrong hopefully with software, z motors not working and I cant figure out port numbers. can I get some clarification plz?

Avatar

By FrankNPrinter 18 March 2017 13:33

Member · 47 comments

don't know what I did but seems to be right now. I had to adjust some of the homing files to fix movement but so far everything appears to be moving correctly again.

Avatar

By FrankNPrinter 21 March 2017 12:16

Member · 47 comments

everything was working but now Y motor on left side appears to be lagging behind the right motor. very odd as they both appear to be powered up just 1 delayed. any idea if I did something wrong here. 2nd y motor is run off 2nd extruder port.
M574 X1 Y1 Z0 S1                    ; set endstop configuration (X and Y and endstops only, at low end, active high)
M667 S1                            ; set CoreXY mode
M350 X16 Y16 E16 I1                        ; Set 16x microstepping with interpolation
M92 X80 Y80 Z4000                    ; Set axis steps/mm
M92 E420:420                        ; Set extruder steps/mm
M906 X800 Y800 Z800 E800            ; Set motor currents (mA)
M201 X800 Y800 Z15 E1000            ; Accelerations (mm/s^2)
M203 X15000 Y15000 Z100 E3600       ; Maximum speeds (mm/min)
M566 X600 Y600 Z30 E20              ; Maximum jerk speeds mm/minute
M208 X200 Y200 Z200                    ; set axis maxima (adjust to suit your machine)
M208 X-8 Y0 Z-0.5 S1                ; set axis minima (adjust to make X=0 and Y=0 the edges of the bed)
G21                                 ; Work in millimetres
G90                                 ; Send absolute coordinates...
M83                                 ; ...but relative extruder moves

; Z probe
M558 P1 X0 Y0 Z1                    ; Analog Z probe, also used for homing the Z axis
G31 Z1.20 P500                      ; Set the probe height and threshold (put your own values here)
; The following M557 commands are not needed if you are using a bed.g file to perform bed compensation
;*** Adjust the XY coordinates in the following M557 commands to suit your build and the position of the Z probe
M557 P0 X60 Y0                      ; Four...
M557 P1 X60 Y165                    ; ...probe points...
M557 P2 X222 Y165                   ; ...for bed...
M557 P3 X222 Y0                     ; ...levelling
;M557 P4 X141 Y82.5                 ; 5th probe point for levelling

; Thermistors and heaters
;*** You can use S and B parameters to define the parameters of the thermistors you are using
M305 P0 R4700 H0 L0                    ; Put your own H and/or L values here to set the bed thermistor ADC correction
M305 P1 R4700 H0 L0                    ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
M305 P2 R4700 H0 L0                    ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
M301 H1 P10 I0.10 D100 T0.50 S1.0    ; PID settings for extruder 0
M301 H2 P10 I0.10 D100 T0.50 S1.0    ; PID settings for extruder 1
M570 S120                            ; Increase to allow extra heating time if needed

Avatar

By FrankNPrinter 21 March 2017 13:05

Member · 47 comments

2nd y motor not always powered up. wiring looks good so going to triple check it but this has killed my printing completely. now just spews piles of molten plastic...

Avatar

By FrankNPrinter 21 March 2017 15:50

Member · 47 comments

found loose connection that was killing motor. now both y run but 1 is really loud and doesn't appear to move correctly like right motor does. anything here indicate different settings between motors?