Fans Only Start At 100%

Avatar

By Syko_Symatic 19 March 2017 23:38

Member · 45 comments

I have built an ultimaker clone and everything is working perfectly apart from my print cooling fans. I have 2 24v fans wired in parallel and connected to Fan 0 on the board. The issue I currently have is that unless I define the fans as running at 100% they do not run at all. Even when starting at 100% and dropping lower they refuse to run below full speed. Any help is appreciated, I have attached my current fan code for reference.

; Fans
M106 P2   ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off
M106 P1 H1 T40 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
M106 P0   ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
Avatar

By dc42 20 March 2017 08:15

Administrator · 2,617 comments

Some fans don't work at all with PWM, and some work only if the PWM frequency is low enough. Try adding parameter F100 to your M106 P0 command.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By Syko_Symatic 20 March 2017 09:38

Member · 45 comments

Will do, could it be an issue with the fans being in parallel?

Avatar

By dc42 20 March 2017 10:09

Administrator · 2,617 comments

I don't think fans in parallel should cause a problem for PWM, but I have never tried it.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By Syko_Symatic 20 March 2017 10:28

Member · 45 comments

Well looks like I have some lunch time investigating to do!

Avatar

By Syko_Symatic 20 March 2017 21:29

Member · 45 comments

After so tweaking and testing it appears that the fans are not PWM capable? Does anyone have a link to 3010 24v fans that definitely are PWM capable?

Avatar

By dc42 20 March 2017 21:35

Administrator · 2,617 comments

I have a 24V E3D 30mm fan arriving tomorrow which I will test with PWM. I think it may be thinner than 10mm. I have some 4010 fans that work well with PWM which came from eBay UK supplier wedo3dprinting. I also have a 50mm 24V blower fan from RS that I planned to use as a print cooling fan, but it doesn't work with PWM at all.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By Syko_Symatic 20 March 2017 21:48

Member · 45 comments

My fans are from E3D as well. Hopefully they will work for you! Then I will know it's something I have done. Though the other days I tested worked fine.

Avatar

By deckingman 20 March 2017 22:22

Member · 796 comments

For additional info. I use a couple of 30mm 12v print cooling fans that I run through a 24 to 12v dc converter and which I control using PWM, but had to drop the frequency right down to 10 Hz.


Avatar

By Sniffle 20 March 2017 23:32

Member · 73 comments

I searched mouser and digikey without any success for a 30x30x10mm fan @ 24v and PWM capable, you have to look at the datasheet usually to see if they are pwm capable and sometimes decipher the manufacturer part number

Avatar

By Syko_Symatic 21 March 2017 12:51

Member · 45 comments
Sniffle wrote

I searched mouser and digikey without any success for a 30x30x10mm fan @ 24v and PWM capable, you have to look at the datasheet usually to see if they are pwm capable and sometimes decipher the manufacturer part number

Thanks Sniffle. I have ordered a few from MakersHut and Ebay. So we shall see. I will check out digikey as well.

Avatar

By dc42 21 March 2017 19:52

Administrator · 2,617 comments

I tried my 24V 30mm fan from E3D. It needs very low PWM frequencies:

12Hz works down to S0.9
10Hz works down to 0.8
8Hz works down to 0.6
5Hz works down to 0.5

Even at S0.999 it is very much quieter than at full speed. My guess is that it after power is applied, the brushless controller waits for around 80ms before it runs the motor.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com

Avatar

By Syko_Symatic 23 March 2017 23:20

Member · 45 comments

Odd? I tried F10 but it still didn't start? I will test it again. On the plus side my eBay fans worked right out of the packet.

So is there a way to set the max speed of the hotel t end fan to make it quieter? If it's much quieter at S0.999 then it seems like the logical thing to do?

Avatar

By elmoret 24 March 2017 03:33

Member · 173 comments

If it's is quieter, it is pushing less air. E3D hotends need every bit of that 4CFM, at least with PLA.

Avatar

By dc42 25 March 2017 14:35

Administrator · 2,617 comments

I just tested this 30mm 24V fan http://www.ebay.co.uk/itm/191458206299/. It works with PWM at the default frequency, right down to S0.1. But I can feel that at full PWM it is pushing less air than the E3D fan.

I used to have a fan shroud on my E3D hot end that took a 40mm fan, and I may return to that approach in future if the fan noise annoys me too much.


Duet WiFi hardware designer and firmware engineer
http://www.escher3d.com
https://miscsolutions.wordpress.com