Heater auto tuning - results not affecting

Avatar

By Nuffe 19 March 2017 18:04

Member · 12 comments

I performed heater tuning for my KosselXL. The results I got were the following:

M307 H1
Heater 1 model: gain 459.4, time constant 241.9, dead time 5.5, max PWM 1.00, mode: PID
Computed PID parameters for setpoint change: P17.1, I0.071, D65.8
Computed PID parameters for load change: P17.1, I1.058, D65.8

M307 H0
Heater 0 model: gain 46.9, time constant 320.8, dead time 1.0, max PWM 1.00, mode: PID
Computed PID parameters for setpoint change: P1221.4, I3.807, D855.0
Computed PID parameters for load change: P1221.4, I253.160, D855.0

I did bed heater tuning with low temperature  because it seems I am not able to reach more than 70C currently with my current setup.
In any case, from the above results I created the following config.g lines:
H307 H0 A46.9 C320.8 D1.0 B0
H307 H1 A459.4 C241.9 D5.5 B0

After reboot (and multiple different reset tries) when I run M307, I got the following results:
7:45:39 PM M307 H1
Heater 1 model: gain 340.0, time constant 140.0, dead time 5.5, max PWM 1.00, mode: PID
Computed PID parameters for setpoint change: P13.4, I0.095, D51.4
Computed PID parameters for load change: P13.4, I0.949, D51.4
7:45:37 PM M307 H0
Heater 0 model: gain 90.0, time constant 700.0, dead time 10.0, max PWM 1.00, mode: bang-bang

So, hotend goes to PID mode, but only dead time is affected. Gain and time constant are incorrect. Bed is reported to be in bang-bang mode.

I am using 1.18beta3 version. But I think I had similar problems earlier too. I do not have config-override.g file and there is no any M301 settings in the config.g file.

Avatar

By vwegert 19 March 2017 19:35

Member · 12 comments

Are you sure you didn't mean to place M307 commands instead of H307 in your config.g...?
(Just went through the PID tuning process myself, that's why I noticed it - I'm not in any other way qualified to comment on your issue...)

Last edited by vwegert (19 March 2017 19:36)

Avatar

By Nuffe 19 March 2017 21:19

Member · 12 comments

😁 Thanks.